Back to overview

Production Incident – RKI requests rejected due to temporary service constraint within the RKI provider’s platform

Feb 27, 2026 at 10:42am UTC
Affected services
Ascend Distribution API

Resolved
Feb 27, 2026 at 10:42am UTC

🚨 Production Incident Notification
Title: Production Incident – RKI requests rejected due to temporary service constraint within the RKI provider’s platform
Date: 27 February 2026
Duration: 26 February 2026 08:42 UTC – 27 February 2026 10:42 UTC (≈ 26h)
Status: Mitigated (running on backup provider infrastructure)

Incident Summary

Starting at 08:42 UTC on 26 February 2026, terminals began experiencing errors when attempting to retrieve RKI keys via Ascend.

The issue was caused by a temporary service constraint within the RKI provider’s platform, resulting in new RKI requests being rejected.

The issue was identified on 27 February 2026 following investigation triggered by terminal error reports and support queries.

Impact
- Terminals attempting Remote Key Injection (RKI) during the incident window were unable to retrieve keys
- Existing terminals already provisioned were not affected
- No data loss or security impact occurred

Cause
The external RKI provider experienced a temporary service constraint affecting their primary RKI endpoint. This resulted in rejection of new RKI requests during the incident window.

The provider returned application-level error responses indicating request rejection. These differed from the connectivity error conditions currently monitored by Ascend, and therefore did not immediately trigger automated alerts.

Monitoring has since been expanded to detect these additional error conditions.

Resolution
The RKI service provider was contacted to investigate and restore full service.

To restore operational continuity, Miura re-routed RKI traffic to the provider’s backup infrastructure. This mitigation was completed on 27 February 2026 at 10:42 UTC, after which RKI operations resumed.

While operating on the backup infrastructure:
- Response times may be slightly slower than normal
- In some cases, for re-injections, retries may be required if an initial attempt fails

The RKI provider is currently working to restore full service on the primary infrastructure, with an estimated recovery timeframe of 2–3 days.

Return to Primary Infrastructure
The RKI provider is currently working to restore their primary infrastructure, with an estimated recovery timeframe of 2–3 days.

Once the provider confirms the primary endpoint is fully operational, Miura will perform validation testing and then switch traffic back from the backup server to the primary server.

Next Steps / Preventive Actions
- Monitoring has been extended to detect a broader range of provider-level error conditions, with alerts now configured in Miura internal monitoring channels
- The Ascend status page will be updated to include dedicated monitoring of the RKI service
- Miura is working closely with the RKI provider to:
- Confirm root cause
- Restore primary infrastructure
- Ensure long-term service stability
- Monitoring and alerting coverage is being reviewed to further strengthen early detection capabilities